<!doctype html>
<html>
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <title>华为欧拉 openEuler 21.09 创新版正式发布：新增文件系统 EulerFS，内核升级，覆盖全场景 - IT之家</title>
    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7; IE=EDGE" />
    <meta name="description" content="新增容器操作系统 KubeOS 和安全容器等大颗粒特性，夯实云化基座；同时发布了 openEuler 21.09 Edge 和 openEuler 21.09 Embedded 版本，探索全场景能力。" />
    <meta name="keywords" content="欧拉,openEuler,华为,linux" />
    <meta http-equiv="pragma" content="no-cache">
    <meta http-equiv="Cache-Control" content="no-cache, must-revalidate">
    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.ithome.com/rss/" />
    <meta http-equiv="expires" content="0">
    <meta name="format-detection" content="telephone=no" />

<link href="//www.ithome.com/css/site.min.css?v=2.23.200814" rel="stylesheet" type="text/css" />

    <link rel="icon" href="//www.ithome.com/favicon.ico" mce_href="//www.ithome.com/favicon.ico" type="image/x-icon" />
    <link rel="shortcut icon" href="//www.ithome.com/favicon.ico" />
    <link rel="apple-touch-icon" href="/img/t.png" />
    
    <link rel="canonical" href="https://www.ithome.com/0/578/688.htm" />
        <link href="//img.ithome.com/file/css/card/1.css?v=2.3.210429" rel="stylesheet" type="text/css" />
        <link href="//www.ithome.com/css/detail.min.css?v=2.3.210429" rel="stylesheet" type="text/css" />

    <script src="//img.ithome.com/file/js/ua.min.js?v=2.1.200731" type="text/javascript"></script>
</head>
<body class="soft" >
    <div id="top">
        <div class="bb">
            <a href="https://www.ithome.com" id="logo"></a>
            <a href="https://img.ithome.com/app/songs/index.html" id="music" target="_blank"></a>
            <div class="fl">
                <div class="mt sel">
                        <a href="https://www.ithome.com" class="l">首页</a>
                </div>
                <div class="mt"><a href="https://quan.ithome.com" class="l">IT圈</a></div>
                <div class="mt"><a href="https://www.lapin365.com" class="l">辣品</a></div>
                
            </div>
            <div class="fr">

                
                <div class="mt" id="settings">
                    <a href="###" class="s">设置</a>
                    <ul class="mu">
                        <li>
                            <span>日夜间</span> <div id="dark-mode"><div>白天</div></div>
                        </li>
                        <li>
                            <span>主题色</span> <div id="nav-color"><div>黑色</div></div>
                        </li>
                    </ul>
                </div>
                <div class="mt"><a href="https://dyn.ithome.com/tougao/">投稿</a></div>
                <div class="mt">
                    <a href="###" class="s">订阅</a>
                    <ul class="mu">
                        <li><a href="//www.ithome.com/rss/">RSS订阅</a></li>
                        <li><a href="#" title="IT之家" rel="sidebar" onclick="addFav();">收藏IT之家</a></li>
                    </ul>
                </div>
                <div class="mt so">
                    <a href="https://www.ruanmei.com" class="s">软媒应用</a>
                    <ul class="mu">
                        <li><a href="//m.ruanmei.com/" target="_blank">App客户端</a></li>
                        <li><a href="//mytime.ruanmei.com" target="_blank">云日历</a></li>
                        <li><a href="//mofang.ruanmei.com/" target="_blank">软媒魔方</a></li>
                        <li><a href="//qiyu.ruanmei.com/" target="_blank">旗鱼浏览器</a></li>
                    </ul>
                </div>
                <div id="toplogin" class="mt">
                    <div class="init"></div>
                </div>
            </div>
        </div>
    </div>
    <script>
        var nightMode = false;
        if (document.cookie.indexOf("nightMode=1") >= 0) {
            document.body.className += " night";
            nightMode = true;
        }
        var navColor = "";
        if (document.cookie.indexOf("navColor=red") >= 0) {
            document.body.className += " red";
            navColor = "red";
        }
    </script>

    <div id="nav" class="bb">
        <div class="fl">
                <div>
                    <a href="//it.ithome.com" target="_blank">业界</a>
                    <a href="//mobile.ithome.com/" target="_blank">手机</a>
                    <a href="//www.ithome.com/pc/" target="_blank">电脑</a>
                    <a href="//www.ithome.com/labs/" target="_blank">测评</a>
                    <a href="//www.ithome.com/video/" target="_blank">视频</a>
                    <a href="//www.ithome.com/original/" target="_blank">原创</a>
                    <a href="//next.ithome.com/" target="_blank">AI</a>
                    <a href="//www.ithome.com/apple/" target="_blank">苹果</a>
                    <a href="//iphone.ithome.com/" target="_blank">iPhone</a>
                    <a href="//hmos.ithome.com/" target="_blank">鸿蒙</a>
                    <a href="//auto.ithome.com" target="_blank">汽车</a>
                </div>
                <div>
                    <a href="//soft.ithome.com/" target="_blank">软件</a>
                    <a href="//digi.ithome.com/" target="_blank">数码</a>
                    <a href="//www.ithome.com/college/" target="_blank">学院</a>
                    <a href="//www.ithome.com/tu/" target="_blank">图赏</a>
                    <a href="//game.ithome.com/" target="_blank">游戏</a>
                    <a href="//www.ithome.com/live/" target="_blank">直播</a>
                    <a href="//www.ithome.com/5g/" target="_blank">5G</a>
                    <a href="//www.ithome.com/microsoft/" target="_blank">微软</a>
                    <a href="//win10.ithome.com/" target="_blank">Win10</a>
                    <a href="//win11.ithome.com/" target="_blank">Win11</a>
                    <a href="//www.ithome.com/zt/" target="_blank">专题</a>
                </div>
        </div>
        <div class="fr">
            <div class="search"><input type="text" placeholder="请输入关键词" name="q" autocomplete="off"><button name="sa">搜索</button></div>
            <div class="hotkeyword">
            </div>
        </div>
    </div>

    <div id="tt" class="bb">
        
    </div>
    







<div id="dt" class="bb clearfix">
    <div class="fl content">
        <div class="cv">
            <a href="//www.ithome.com">首页</a> <span class="sub">&gt;</span> <a href="https://soft.ithome.com/">软件之家</a><span class="sub">&gt;</span><a href="https://soft.ithome.com/linux">Linux</a>
        </div>

        <h1>华为欧拉 openEuler 21.09 创新版正式发布：新增文件系统 EulerFS，内核升级，覆盖全场景</h1>

        <div class="info clearfix">
            <div class="l">

                    <span id="pubtime_baidu">2021/10/1 11:59:38</span>
                    <span id="source_baidu">来源：<a href="https://www.ithome.com/0/578/688.htm" target="_blank">IT之家</a></span>
                    <span id="author_baidu">作者：<strong>在水</strong></span>

                    <span id="editor_baidu">责编：<strong>在水</strong></span>
            </div>

            <div class="r">

                <span id="hitcount"></span>
                    <a href="#ifcomment" class="pti_comm">评论：<span id="commentcount"></span></a>
            </div>
        </div>



        <div class="post_content" id="paragraph">
            <p data-vmark="2d96"><a class="s_tag" href="https://www.ithome.com/" target="_blank">IT之家</a> 10 月 1 日消息 据华为 openEuler 官方宣布，2021 年 9 月 30 日，全新 openEuler 21.09 创新版如期而至。</p><p data-vmark="eb31"><img src="//img.ithome.com/images/v2/t.png" w="1080" h="359" class="lazy" title="华为欧拉 openEuler 21.09 创新版正式发布：新增文件系统 EulerFS，内核升级，覆盖全场景" srcset="https://img.ithome.com/newsuploadfiles/2021/10/a8d46e92-ff13-40a0-987f-dff8fa8b3e0f.jpg 2x" data-original="https://img.ithome.com/newsuploadfiles/2021/10/a8d46e92-ff13-40a0-987f-dff8fa8b3e0f.jpg@s_2,w_820,h_273" width="1080" height="273"></p><p data-vmark="7203">openEuler 21.09 是欧拉正式升级面向数字基础设施的开源操作系统后的第一个社区创新版本。伴随社区的快速发展，面向场景化的 SIG 不断组建，openEuler 的应用边界从最初的服务器场景，逐步拓展到云计算、边缘计算、嵌入式等更多场景。</p><p data-vmark="4158">IT之家获悉，openEuler 21.09 推出面向新型介质的文件系统 EulerFS，持续内核创新，新增容器操作系统 KubeOS 和安全容器等大颗粒特性，夯实云化基座；同时发布了 openEuler 21.09 Edge 和 openEuler 21.09 Embedded 版本，探索全场景能力。</p><p data-vmark="c83b">openEuler 对来自社区的 869 名参与 openEuler 21.09 版本贡献的开发者表示感谢。同样感谢积极参与该版本贡献的华为、联通数科、中国电信、青云科技、麒麟软件、统信软件、中科院软件所、上海交通大学等公司、研究机构和高校。</p><p data-vmark="a413">openEuler 21.09 作为第一个覆盖全场景的社区创新版正式推出。</p><p data-vmark="ff23"><img src="//img.ithome.com/images/v2/t.png" w="1080" h="521" class="lazy" title="华为欧拉 openEuler 21.09 创新版正式发布：新增文件系统 EulerFS，内核升级，覆盖全场景" srcset="https://img.ithome.com/newsuploadfiles/2021/10/115d05d1-d486-43b9-a8b7-2bad6b2568c0.jpg 2x" data-original="https://img.ithome.com/newsuploadfiles/2021/10/115d05d1-d486-43b9-a8b7-2bad6b2568c0.jpg@s_2,w_820,h_396" width="1080" height="396"></p><p data-vmark="2cff">openEuler 21.09 系统架构和新特性如下：</p><p data-vmark="255b"><img src="//img.ithome.com/images/v2/t.png" w="1080" h="596" class="lazy" title="华为欧拉 openEuler 21.09 创新版正式发布：新增文件系统 EulerFS，内核升级，覆盖全场景" srcset="https://img.ithome.com/newsuploadfiles/2021/10/32d16261-2342-40be-b141-957df68b2e75.jpg 2x" data-original="https://img.ithome.com/newsuploadfiles/2021/10/32d16261-2342-40be-b141-957df68b2e75.jpg@s_2,w_820,h_453" width="1080" height="453"></p><p data-vmark="0297"><strong>内核创新</strong></p><p data-vmark="3653">openEuler 21.09 对云原生调度的相关功能进行了增强。对于云场景在线和离线业务混合部署场景，创新 CPU 调度算法和 OOM 内存回收算法，保障在线业务对 CPU 的实时抢占及抖动抑制，支撑在线业务安全可靠运行。</p><p data-vmark="86dd">在文件系统方面，openEuler 21.09 新增 EulerFS 文件系统。EulerFS 是华为开发并贡献到社区的全新文件系统，针对 SCM 新型介质，采用了软更新和双视图技术，减少文件系统元数据同步时延，相比 EXT4 文件系统，性能倍级提升。</p><p data-vmark="6dd7">在内存管理方面，内存分级扩展 etMem 新增用户态 swap 功能。实现策略配置淘汰的冷内存交换到用户态存储，性能优于内核态 swap 且业务无感知。</p><p data-vmark="43ef"><strong>夯实云化基座</strong></p><p data-vmark="128a">K8S 已经成为事实上的云原生基础设施底座，业界主流操作系统厂商均基于 K8S，推出云原生场景专用容器 OS（如 Redhat RCHOS，AWS BottleRocket 等），提供与业务容器一致的管理和运维体验。</p><p data-vmark="dba5">openEuler 21.09 紧跟业界的最新技术趋势，华为将原创的容器化操作系统 KubeOS 贡献到社区，具备运行内存消耗 &lt; 150M，重启时间 &lt; 15 秒的优势。</p><p data-vmark="d91c">openEuler 21.09 结合 StratoVirt、iSulad、ShimV2 形成了安全容器方案，为应用提供一个轻量、安全的执行环境，隔离容器和宿主机操作系统间、容器间的安全风险。该方案由华为贡献到社区，较传统 Docker+QEMU 方案，底噪和启动时间优化 40% 以上。</p><p data-vmark="9d8f">KubeSphere 是在 K8S 之上构建的以应用为中心的容器平台，由青云科技发起，并欧拉开源社区的 KubeSphere SIG 提供支持和维护。</p><p data-vmark="04b1">OpenStack 版本更新到 Wallaby。Wallaby 是 2021 年 4 月份发布的最新稳定版本，包含 nova、kolla、cyborg、tacker 等核心项目的重要更新。由联通数科、中国电信、华为共同发起，并由欧拉开源社区 OpenStack SIG 提供支持和维护。</p><p data-vmark="1362">Eggo 是基于 K8S 的双平面集群部署工具，提供高效稳定的集群部署能力，支持单集群多架构、在线和离线等多种部署模式。Eggo 结合 GitOps 管理能力、感知集群配置变化，驱动集群 OS 统一高效部署，百节点部署时间从几个小时降为 15 分钟之内。Eggo 由华为主导研发，未来将由 Cloud Native SIG 负责开发维护。</p><p data-vmark="a3e6"><strong>探索全场景创新</strong></p><p data-vmark="ee8f">openEuler 21.09 针对边缘计算场景发布了 openEuler 21.09 Edge。该版本集成了 KubeEdge 和边云协同框架，具备边云应用统一管理和发放等基础能力，未来将通过增强智能协同提升 AI 易用性和场景适应性，增强服务协同实现跨边云服务发现和流量转发，增强数据协同提升南向服务能力。</p><p data-vmark="edcb">openEuler 21.09 针对嵌入式场景发布了超轻量级嵌入式版本 openEuler 21.09 Embedded。该版本镜像小于 5M，启动时间小于 5 秒，提供轻量化、安全和轻量容器等基础能力，支持 ARM32、ARM64 芯片架构，未来将协同欧拉开源社区生态伙伴、用户、开发者，逐步扩展支持 PowerPC、RISC-V 等芯片架构，增加确定性时延、工业中间件、仿真系统等能力，打造嵌入式领域操作系统解决方案。</p><p data-vmark="3995">openEuler 21.09 Edge 和 openEuler 21.09 Embedded 是欧拉开源操作系统场景的探索和拓展，提供预览性质的技术创新体验，社区将持续丰富边缘计算和嵌入式场景的能力。</p><p data-vmark="be90"><strong>中间件 &amp; 桌面环境</strong></p><p data-vmark="91ab">OpenResty 目前已经移植到 openEuler 21.09 版本中。OpenResty 是一个基于 Nginx 与 Lua 的高性能 Web 平台。用于方便地搭建能够处理超高并发、扩展性极高的动态 Web 应用、Web 服务和动态网关。感谢来自 Apache APISIX 社区的罗泽轩、温铭在本次 OpenResty 迁移工作中的贡献，让 OpenResty 可以在欧拉开源操作系统上平稳高效的运行。</p><p data-vmark="3ea7">UKUI 是由麒麟团队开发的基于 Linux 发行版的轻量级桌面环境，在 openEuler 21.09 中，UKUI 新增中文输入法和多媒体支持。</p><p data-vmark="2688">统信桌面环境简称 DDE，是一款安全、稳定且易用的 Linux 桌面环境，由统信软件开发。在 openEuler 21.09 中，DDE 新增支持画板、音乐和影院应用。</p>
        </div>

        

            <div class="newsgrade"></div>
        <div class="shareto">
            
            <div class="bdsharebuttonbox">
                <a href="#" class="bds_qzone" data-cmd="qzone" title="分享到QQ空间"></a>
                <a href="#" class="bds_weixin" data-cmd="weixin" title="分享到微信"></a>
                <a href="#" class="bds_tsina" data-cmd="tsina" title="分享到新浪微博"></a>
                <a href="#" class="bds_tqq" data-cmd="tqq" title="分享到腾讯微博"></a>
                <a href="#" class="bds_renren" data-cmd="renren" title="分享到人人网"></a>
                <a href="#" class="bds_more" data-cmd="more"></a>
                <a class="bds_count" data-cmd="count"></a>
            </div>
            <a class="down_app" href="//m.ruanmei.com/d/it/" target="_blank">下载IT之家APP，分享赚金币换豪礼</a>
        </div>

        <!-- 相关文章 -->
        <div class="related_post"><div class="title"><h2>相关文章</h2><div class="hot_tags"><span>关键词：<a href='/tag/oula/' target='_blank'>欧拉</a>，<a href='/tag/openeuler/' target='_blank'>openEuler</a>，<a href='/tag/huawei/' target='_blank'>华为</a>，<a href='/tag/linux/' target='_blank'>linux</a></span></div></div><ul class="list_3"><li><a target="_blank" href="https://www.ithome.com/0/578/648.htm">华为商城简化传统物流过程，最快 30 分钟送达</a></span></li><li><a target="_blank" href="https://www.ithome.com/0/578/585.htm">鸿蒙 HarmonyOS 开发必备工具，华为 DevEco Studio 3.0 正式发布</a></span></li><li><a target="_blank" href="https://www.ithome.com/0/578/583.htm">消息称华为鸿蒙 HarmonyOS 3.0 将很快到来</a></span></li><li><a target="_blank" href="https://www.ithome.com/0/578/528.htm">索尼互娱起诉华为，称后者智能手表不能用“GT”名称</a></span></li><li><a target="_blank" href="https://www.ithome.com/0/578/491.htm">华为：全球率先通过汽车网络安全 ISO/SAE 21434 认证</a></span></li><li><a target="_blank" href="https://www.ithome.com/0/578/464.htm">郭平当选华为轮值董事长：公司最高领袖，任期半年</a></span></li></ul></div>

        <script>
            if (nightMode) {
                document.write('<iframe align="middle" src="//www.ithome.com/block/dajia.html?night=1" scrolling="no" marginwidth="0" marginheight="0" frameborder="0" class="dajia"></iframe>');
            } else {
                document.write('<iframe align="middle" src="//www.ithome.com/block/dajia.html" scrolling="no" marginwidth="0" marginheight="0" frameborder="0" class="dajia"></iframe>');
            }
        </script>

            <iframe src="about:blank" align="middle" data="bb1f718069440cc8" datalapin="" scrolling="no" marginwidth="0" marginheight="0" frameborder="0" width="100%" height="360" id="ifcomment"></iframe>
    </div>
    <div class="fr fx">
        <div id="rank" class="tab-list">
            
        </div>

        <div class="cat-list" id="cat-hot">
        </div>

    </div>
</div>



    <div id="fls" class="bb">


    <p>
        <strong>软媒旗下网站：</strong>
        <a href="//www.ithome.com/" target="_blank">IT之家</a>
        <a href="//www.lapin365.com/" target="_blank">辣品 - 超值导购，优惠券</a>
        <a href="//www.zuihuimai.com/" target="_blank">最会买 - 返利返现优惠券</a>
        <a href="https://iphone.ithome.com/" target="_blank">iPhone之家</a>
        <a href="//www.win7china.com/" target="_blank">Win7之家</a>
        <a href="//win10.ithome.com/" target="_blank">Win10之家</a>
        <a href="https://win11.ithome.com/" target="_blank">Win11之家</a>
    </p>

    <p>
        <strong>软媒旗下软件：</strong>
        <a href="//mofang.ruanmei.com/" target="_blank">魔方</a>
        <a href="//qiyu.ruanmei.com/" target="_blank">旗鱼浏览器（极速内核）</a>
        <a href="//mytime.ruanmei.com/" target="_blank">云日历</a>
        <a href="http://www.cooldock.com/" target="_blank">酷点桌面</a>
        <a href="//www.win7china.com/windows7master/" target="_blank">Win7优化大师</a>
        <a href="//win10.ithome.com/windows10master/" target="_blank">Win10优化大师</a>
        <a href="//m.ruanmei.com/" target="_blank">软媒手机APP应用</a>
    </p>


        
    </div>


    <footer>
        <div id="lns">
            <a href="//www.ithome.com/about.htm" target="_blank">关于IT之家</a>
            |<a href="//www.ruanmei.com/aboutus/" target="_blank">关于软媒</a>
            |<a href="//www.ruanmei.com/contact/" target="_blank">联系我们</a>
            |<a href="//www.ruanmei.com/joinus/" target="_blank">加入软媒</a>
            |<a href="//m.ithome.com/" target="_blank">WAP版</a>
            |<a href="//www.ithome.com/sitemap/" target="_blank">网站地图</a>
            |<a href="//www.ithome.com/archiver/" target="_blank">Archiver</a>
            |<a href="http://www.cike.cn/" target="_blank">刺客团队</a>
        </div>
        <div id="fi">
            <p>IT之家，软媒旗下科技门户网站 - 爱科技，爱这里。</p>
            <p>Copyright &copy;<a href="//www.ruanmei.com" target="_blank">RuanMei.com</a>, All Rights Reserved.</p>
            <p>
                <a href="//www.ruanmei.com/" target="_blank">软媒公司</a>版权所有
                
        </div>
    </footer>

    <script src="https://s3.pstatp.com/cdn/expire-1-w/jquery/3.4.0/jquery.min.js"></script>
    <script>(window.jQuery || document.write("<script src='https:\/\/img.ruanmei.com\/btd\/cdn\/expire-1-w\/jquery\/3.4.0\/jquery.min.js'><\/script>"));</script>
    <script src="https://s3.pstatp.com/cdn/expire-1-M/jquery-cookie/1.4.1/jquery.cookie.min.js"></script>
    <script>(window.jQuery && window.jQuery.fn && window.jQuery.fn.cookie || document.write("\u003Cscript src=\u0022https:\/\/img.ithome.com\/file\/js\/jquery\/jquery.cookie.js\u0022\u003E\u003C\/script\u003E"));</script>
    <script src="https://s3.pstatp.com/cdn/expire-1-M/jquery.lazyload/1.9.1/jquery.lazyload.min.js"></script>
    <script>(window.jQuery && window.jQuery.fn && window.jQuery.fn.lazyload || document.write("\u003Cscript src=\u0022https:\/\/img.ithome.com\/file\/js\/jquery\/jquery.lazyload.js\u0022\u003E\u003C\/script\u003E"));</script>
    <script src="//img.ithome.com/file/js/jquery/popwin.js?v=2.22.200813"></script>
    <script src="//img.ithome.com/file/js/v2.3/common.js"></script>
    

     <script src="//img.ithome.com/file/js/site.min.js?v=2.23.200828"></script>

    
    
    <script type="text/javascript" id="bdshare_js" data="type=tools&uid=192225"></script>
    <script>
        var thumb = $('.post_content img').eq(0).attr("src"), title = $("h1").text(), desc = $("meta[name=description]").attr("content");
        if (desc.length > 85 - title.length) {
            desc = desc.substring(0, 85 - title.length)
        }
        window._bd_share_config = { "common": { "bdSnsKey": { "tsina": "1369706960", "tqq": "801077952" }, "bdText": "【" + title + "】" + desc + " - 分享自 @IT之家 下载APP立得金币换豪礼！下载：https://m.ithome.com/ithome/download/ 详情：", "bdMini": "2", "bdMiniList": false, "bdPic": thumb, "bdStyle": "1", "bdSize": "32" }, "share": {} };
        with (document) 0[(getElementsByTagName('head')[0] || body).appendChild(createElement('script')).src = '//img.ithome.com/static/api/js/share.js?v=86835285.js?cdnversion=' + ~(-new Date() / 36e5)];
    </script>

    
        <script type="text/javascript" src="//dyn.ithome.com/grade/578688"></script>
        <script>
            $(".newsgrade").html(gradestr);
        </script>
    <script src="//img.ithome.com/file/js/prettify/prettify.js"></script>

    
        <script src="//cmt.ithome.com/api/comment/count?newsid=578688"></script>
            <script type="text/javascript" src="//dyn.ithome.com/api/hitcount/578688/pc"></script>
    <script>
        
        $("#tt").load('https://www.ithome.com/block/tt.html?' + new Date().getTime());
        
        $("#rank").load('//www.ithome.com/block/rank.html');
        
        $("#cat-hot").load('//www.ithome.com/block/cat/181.html');
        
        $(function () { $("img.lazy").lazyload(); });
        
        $("pre").addClass("prettyprint");prettyPrint();
    </script>

    <div style="display:none">
        <script>
            var _hmt = _hmt || [];
            (function () {
                var hm = document.createElement("script");
                hm.src = "https://hm.baidu.com/hm.js?cfebe79b2c367c4b89b285f412bf9867";
                var s = document.getElementsByTagName("script")[0];
                s.parentNode.insertBefore(hm, s);
            })();
        </script>
    </div>
</body>
</html>
